The Workbench 2016-12

  • Posted on: 11 December 2016
  • By: tomww

News From The Workbench 2016-12

Prepare for C-Compilers defaulting to 64-bit

As many distributions move towards 64-bit as default for binaries, so does the upcoming Solaris 12. You can see this for instance in the userland source gate on One main change is, that the new developerstudio compiler versions and OSDistro delivered "gcc" default to "-m64", that means, if you don't specify the bitness, you create 64-bit objects by default. Therefore I'm testing a change for include/<||> which explicitly sets "-m32" for the C-compilerflags. The include file already has the switch "-m64". For the non-64-bit targets you'll most likely run into errors like "wrong ELF format" if the switch "-m32" is missing.

To be clear, Solaris continues to support (most of the) 32-bit and 64-bit binaries at the same time. Only the Kernel lost the ability to boot in 32-bit mode some longer time ago. The kernel being 64-bit boot-mode only is not a big deal, as Solaris continues to allow the ABI for 32-bit userland programs. Most of the public libraries are still delivered in dual-arch packages, so you have /usr/lib for 32-bit and /usr/lib/$ARCH/ for 64-bit. Read this blog for more details: Moving Oracle Solaris to LP64 bit by bit

Recompiling packages for Solaris 12 (development)

This time before you issue "pkg update -v" please make a snapshot of your bootenvironment with "beadm create solaris12@pre-pkg-update-meaningful-xyzxyz". It is for you just in case SFE packages mix up with the update.

I'm recompiling libraries for Solaris 12 Build 112 (this is non-public you know). So if you are one of the lucky Solaris 12 testers, then you can enjoy watching video with vlc or mplayer, as well as watching mp4 videos in firefox 45 with the help of ffmpeg. These are the multimedia targeting packages, but I plan to recompile every package which has been compiled before (builds 79 and 88). Around build 100++ so many things have changed so it is best to recompile all SFE packages. One example is that package names have changed, gnome3 came in and so on.

Please expect the IPS repository "localhosts12" contents to change frequently and have a higher risk of broken dependencies or libraries only for Solaris 12 (IPS publisher "localhosts12"). Please consider setting this "localhosts12" publisher to "--disable" in case you need a stable SFE stack over the next few weeks. I'm sorry for this type of inconvenience. We have to go this way for now, until there is an initiative from you, dear users, to help building a "release" repository with tested/stable packages. If you want to help, please stand up now (sfepackages at g mail dod com). It will be a learning curve for you, but I don't know other options yet.


LibreOffice5 for Solaris 11, 12, OpenIndiana

I've done preparations for creating new packages with the major number "5". It's been lots of small changes and litte tweaks to other packages and include files. But this should be almost finished now. So it's a matter of time until I find a day or two to actually do the package creation, test them and eventually eliminate new issues/bug.
I dont' really want to break the old package stack by mixing up new library versions.

If you are currently waiting with your LibreOffice install because you insist on verison "5", well, to be honest, then I can't help you today. LibreOffice4 is of such good quality that you shouldn't wait installing it today.


pkgbuild 1.3.105 is latest one, now collecting issues / bugs to eventually make an update

With a little luck, I can take over the source for pkgbuild. Things aren't finished today, but I hope to take over the source soon.
Do you have issues with pkgbuild on your OSDistro? If yes, then please tell me the details. In case you have a patch or a workaround, I happily receive the (prelimiary) patches and instructions for workarounds from you.

Translation of this blog wanted

If you feel that your mother language should be represented in e.g. the articles like "quicklinks to repositories" here on the blog, then please get in contact with me. I can arrange that you can have a translated page in your mother language. I could think that for e.g. Japanese or Simplified Chinese or Russian, French, Spanish, Swiss German, Austrian German, Swaheli or any other language could help new users very much to get to speed with SFE packages quickly. I'm very much interestet in non-western langugages. Please consider volunteering.
Please, write me an email to sfepackages at g mail dod com if you feel you can do such a simple translation for mainly this first and most important page: Quick links to Repositories

New functions for this drupal blog

I've added a bunch of new modules to this drupal blog site. Just in case you see errors or some odd behaviour, please drop me a note and speficy what doesn't work. So I get a chance to fix this.
My call in the previous section about translastion has been serious. So I prepared the site for being able to carry multiply versions of one article, the original one in english language and copies in your favourite translation.

Feeeeeeedbaaaaaaack please

Feedback is the fuel for OpenSource programmers. They *need* to know that you like the fruits. If you have some nice words, and even if you have some critics/issues, please do not hesitate to tell them. It only can make everything better and stronger!

As always, to know if things are going the right path for you, I strongly encourage you to give feedback. Tell me what works for you, which packages are most important to you and on which packages you're waiting badly.
Drop a comment here on the blog or write on twitter @sfepackages, or write me an email to sfepackages at g mail dod com.

I very much hope you have fun with the SFE packages and can make good use of them.






First off, thanks for the hard work.
In s12 113+ libreoffice wont install as there where some changes (in fact I had to uninstall libreoffice to be able to upgrade to a latter version).

From the output it seems as the dependency of gstreamer brakes the install.
pkg install -v libreoffice4-desktop-int libreoffice4
pkg install: No matching version of desktop/application/libreoffice4-desktop-int can be installed:
Reject: pkg://localhosts12/desktop/application/libreoffice4-desktop-int@
Reason: No version matching 'require' dependency desktop/application/libreoffice4 can be installed
Reject: pkg://localhosts12/desktop/application/libreoffice4@
Reason: All acceptable versions of 'require' dependency on library/audio/gstreamer@0.10.32- are obsolete
Reject: pkg://localhosts12/desktop/application/libreoffice4-desktop-int@
Reason: No version matching 'require' dependency desktop/application/libreoffice4 can be installed
No matching version of desktop/application/libreoffice4 can be installed:
Reject: pkg://localhosts12/desktop/application/libreoffice4@
Reason: [already rejected; see above]

Thanks again.

Hi Eli,
thank you very much :)

Good catch! Right tonight when I tried myself to update to 113 I've discovered the same. I've already done a quick change to the manifest and this is, to completely drop this gstreamer dependency (until I have a complete fix).

So the repo should now show a libreoffice4 with timestamp of today. If you could test this, that would be cool.
On my system I've uninstall libreoffice and do the update 112 -> 113 at the moment. So only after this I can test if there are more/other possible packages which show conflicts.

If you can install libreoffice4 with the package from tonight, then please drop me a note!

Have fun with Libreoffice!


PS: I for my part never forget Peter from Australia who did and still does the most important part of the libreoffice works for Solarish-Platforms in SFE :-) So I'm passing on attributions to him.

Today I had a chance to try and re-install.
Yes the install worked flawless, all I can say it works like a charm.

I really, really appreciate your hard work.
P.S. When I upgraded to 113 I had to uninstall which was really a shame, I am really glade to have it back.
Thanks again for all the hard work.

Hi Eli,

I'm pleased to read that LibreOffcie4 is making fun and is useful to you. In such cases I remember the day when LibreOffice4 worked the first time after spending days of building prerequisites and weeding out errors.

Today I've upgraded to build 114 while LibreOffice4 was installed. So just dropping the gstreamer dependency looks like a very good interim solution until .... unitil I find some time to get LibreOffice5 compiled on my autobuild system. I hope to get this done before the congress 33C3 end of december takes place.

Just in case, this one is true as well for S12:


PS: And there is Peter Tribble who did much earlier a huge amount of work to get LibreOffice4 to tribblix OS and I believe we've been wangling a lot of tweaks and patches there.

Recently x264 and ffmpeg got an update.

If you accidentially installed ffmpeg in version 3.x.x, then please uninstall it again. The currently targeted version for ffmpeg ist 2.8.10.

Libx264 got an update from version to, but I got a report that the vlc package with timestamp of 20160611 looks like not working with updates x264 lib.

You could manually install to exactly version x264 or wait a few days until I got VLC itself updated and tested (Update 20161223: vlc re-compiled, tests promising). You may as well help with testing and sending in diffs in case you are familiar with compiling.

I'm sorry to the inconvenience and so I take the chance to remember: You can volunteer to build up a "release" repository where a single broken package can't easily slip in.


Update 20161223 for Solaris 11 localhosts11 repository

VLC is now recompiled against x264 from 20160529, so you may want to update to this package or newer:
vlc@2.1.5,5.11- (note the timestamp: 20161222 = new!)

Please report if vlc works again for you on Solaris 11.


From the build machine, libreoffice- compiled!

[build MOD] libreoffice
[build BIN] top level modules: libreoffice
[build ALL] top level modules: build-non-l10n-only build-l10n-only

I'll test tomorrow and let you know when you can install a very early testing package!
Anyone intersted in testing LibreOffice 5.2, please drop me a note so I can send you a message when the package is ready. If that package works, I'll next updated to the very latest version and this is the one we should test more.


It showed up, that Gtk doesn't init propperly.
I'll try patching the source so it can run with the older Gtk 2.20 which is available on Solaris 11.
Stay tuned!

Do you want to test LibreOffice5? If yes, please drop me a note so I can send you a message once LO5 is available!


I've removed 4.4 and installed LO 5.2.33 with desktop integration (it's in the repo, so I thought it ready to go). I see this error, which I'm guessing is the same as you alluded to above:


Gdk-ERROR **: g_thread_init() must be called before gdk_threads_init()

Willing to try again! Not needing LO at this moment on this computer, so I'll leave things as-is.

I'm running Solaris 11.3, SRU 15.4.

See this mini thread
I had the same issue with LO4

Very good catch!
Again on the build machine g++/glib2 slipped in. And this one is so broken that it is unusable.
I made the spec file for g++/glib2 unusable on my systems, to prevent building it again.

I'll do a new LO52 build and post once it is ready.
Users will need to cleanup first by removing "g++/glib2" "harfbuzz" "libreoffice52" "libreoffice52-desktop-int"
Old LO52 packages willl be removed from the repo and a new one with a new timestamp will appear.

Thanks for this good catch,

rebuild + upload done

I had to manually reinstall harfbuzz. It wasn't installed as a dependency, but it all works now.

Thank you. I've added harfbiuzz manually to the manifest for LibreOffice52. It might help to auto-install harfbuzz until I have a fix integrated into the build instructions.

I think something isn't right with the repository:

root@osol:~> pkg refresh
root@osol:~> pkg info -r libreoffice52
pkg: Invalid content: manifest hash failure: fmri: pkg://localhosts11/desktop/application/libreoffice52@,5.11-
expected: d050afb4fcf49dcb259d47963afee39e1a575718 computed: 1bc8a0c9fca8240cb21b499e0675e49ae22c2d3e. (happened 4 times)

root@osol:~> pkg install -nv libreoffice52
Creating Plan (Package planning: 1/5): \

Errors were encountered while attempting to retrieve package or file data for
the requested operation.
Details follow:

Invalid content: manifest hash failure: fmri: pkg://localhosts11/desktop/application/libreoffice52@,5.11-
expected: d050afb4fcf49dcb259d47963afee39e1a575718 computed: 1bc8a0c9fca8240cb21b499e0675e49ae22c2d3e. (happened 4 times)

Please regenerate the checksums.

I'll create a new package with the harfbuzz dependency in it.
Looks like dicovering IPS features. My first attempt will be to rebuild the repo after the harfbuzz-dependency was added manually to the manifest.

if you re-test, are the package manifest values okay now? The manifest is rebuilt and repo is updated.

Yes, LO52 is installed and it works.

Thank you, Thomas!!

Have fun with LibreOffice 5.2.3!

Next is trying to compile LibreOffice 5.2.4...

And in the meantime I encourage everyone to spread the news about LibreOffice 5 on Solaris 11 on their preferred channels. It can only help the entire project.

My means are quite limited. I think somebody should contact LO distribution team about this news.
Also, SFE should create a simple web page with clear instructions how to register the repo and install LO. Something like this:

pkg set-publisher -G '*' -g localhosts11
pkg install -v libreoffice52 libreoffice52-desktop-int

Then this info could be published on

Meanwhile I provided an answer to this question:


Good read!
If you feel so, you could open an article here on the blog and write a draft, like the text you already sent to ask.libreoffice. I currently have no connection to the LO people, that would be cool if that could be established.
I would appreciate having Solaris/OpenIndiana Libreoffice linked / mentioned on the LO webpackages.
Planned is as well to have "still" as a package too. Pjama added "mediators", so you can have default links to either LO, LO 5.1 still or LO 5.2 fresh.
Any help in public announcements / relations is very welcome, as I prefer to build packages and only second do PR (: .


I created this page
Please review it and feel free to improve it.
I don't know how to make it visible from the main page.
It the page is OK then it's worth to make it visible.

P.S. Thanks for LO !


Looks good!
Would it be a plan to give it a reasonable long-URL ( e.g. "libreoffice52-quick-install" ) and then check the boxes for publishing it?
Both is at the bottom of the editing page, just click through the options "URL..." and "Publishing". You may check all three "published" "promoted..." "sticky".
If anyone else with an account (register one!) wants to review, feel free to comment or improve the text.
Many minds can only make it bigger.

I would only add a marker/link with "...more info on setting IPS pulishers" with a link to the page "quicklinks".

If Libreoffice homepage wants to link to this page, then if would be cool if someone could establish communication with them.

Go for it!


Also vlc must be removed. It also depends on glib2. For a quick paste of commands I needed:

sudo pkg uninstall harfbuzz libreoffice52 libreoffice52-desktop-int vlc g++/glib2

My wine install is now broken. I haven't used it since the last update. It now returns "wine: virtual memory exhausted". In the Linux world, the solution is adding the user running wine to the audio group. What do we do? It used to work for me without having to add myself to any groups, now I get this error. I uninstalled and reinstalled wine with no change in behavior.


wine has got a new build with libumem linked. This may have broken it.
You need to specify the fll package FMRI with an older timestamp to get the previous version back.

"pkg list -avf wine shows all availabe packages


Thanks. The following fixed it after uninstalling the latest wine. I can't believe I have something for which wine is actually useful!

pkg install pkg://localhosts11/desktop/wine@1.9.10,5.11-

This is really really minor, but if you fire up the quickstarter (libreoffice5.2 --quickstart), it doesn't show any of the LO icons like it did in the LO4.4 build. I mention this in case it signals some other problem or build error. Everything still works as far as I can tell.

Have you looked into (or are you even interested in) getting your repo listed somewhere in the LO world as an unsupported or as-is distribution? Perhaps there isn't such a resource. I think it would be great to get the word out about your efforts, and the efforts of those involved with you in this project. Perhaps the LO developers wouldn't be interested.

Perhaps you can post something here: